<!doctype html>
<html lang="en">
<head>
	<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
	<title>Shacknews Presents: Pop! Goes the Culture! - Episode 72 | Shacknews</title>
	<link rel="canonical" href="https://www.shacknews.com/article/131258/shacknews-pgtc-stranger-things-4-review" />
<link rel="amphtml" href="https://www.shacknews.com/article/131258/shacknews-pgtc-stranger-things-4-review?amphtml=1">


	<meta name="description" content="It's time for some more exciting movie and tv talk. Get in here!" />
	<meta property="og:description" content="It's time for some more exciting movie and tv talk. Get in here!"/>
	<meta itemprop="description" content="It's time for some more exciting movie and tv talk. Get in here!"/>
	<meta name="twitter:description" content="It's time for some more exciting movie and tv talk. Get in here!">

	<meta property="og:title" content="Shacknews Presents: Pop! Goes the Culture! - Episode 72"/>
	<meta name="twitter:title" content="Shacknews Presents: Pop! Goes the Culture! - Episode 72">
	<meta itemprop="name" content="Shacknews Presents: Pop! Goes the Culture! - Episode 72"/>

	<meta property="og:image" content="https://d1lss44hh2trtw.cloudfront.net/assets/article/2022/07/07/pop-goes-the-culture-logo_feature.jpg"/>
	<meta itemprop="image" content="https://d1lss44hh2trtw.cloudfront.net/assets/article/2022/07/07/pop-goes-the-culture-logo_feature.jpg"/>
	<meta itemprop="twitter:image" content="https://d1lss44hh2trtw.cloudfront.net/assets/article/2022/07/07/pop-goes-the-culture-logo_feature.jpg"/>

	<meta name="twitter:card" content="summary_large_image"/>



<meta name="twitter:site" content="@shacknews">

<meta property="og:site_name" content="Shacknews"/>

<meta name="ROBOTS" content="INDEX, FOLLOW" />

	<link rel="stylesheet" type="text/css" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/css/style-built.css">

<script>
var STATIC_URL = "https:\/\/d1lss44hh2trtw.cloudfront.net\/deploy\/www-a3b4353\/";
</script>
<script src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/js/article-built.js" type="text/javascript"></script>
	<link rel="apple-touch-icon" sizes="57x57" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192"  href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/favicon-16x16.png">
<link rel="manifest" href="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/favicon/ms-icon-144x144.png">
<meta name="theme-color" content="#ffffff">
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-52037-2"></script>
<script>
	window.dataLayer = window.dataLayer || [];
	function gtag(){dataLayer.push(arguments);}
	gtag('js', new Date());
	gtag('config', 'UA-52037-2');
</script>
	<!-- Begin comScore Tag -->
<script>
var _comscore = _comscore || [];
_comscore.push({ c1: "2", c2: "24936062" });
(function() {
var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=24936062&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->
	<script>
var adUnits = {
	'skin': [''],
	'300x250': [
		'<a href="https://shackpets.shacknews.com/"><img src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/ad/shackpets/300x600.webp" width="300" height="600" /></a>',
		'<a href="https://shackpets.shacknews.com/"><img src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/ad/shackpets/300x250.webp" width="300" height="250" /></a>',
	],
	'300': [
		'<a href="https://shackpets.shacknews.com/"><img src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/ad/shackpets/300x250.webp" width="300" height="250" /></a>',
	],
	'728x90': ['']
}

// var adUnits = {
// 	'skin': [''],
// 	'300x250': [
// 		'<a href="https://store.steampowered.com/app/1117350/GALAHAD_3093/"><img src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/ad/galahad/galahad-mobile.jpg" /></a>',
// 		'<a href="https://store.steampowered.com/app/1117350/GALAHAD_3093/"><img src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/ad/galahad/galahad-article.jpg" /></a>',
// 	],
// 	'300': [
// 		'<a href="https://store.steampowered.com/app/1117350/GALAHAD_3093/"><img src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/ad/galahad/galahad-article.jpg" /></a>',
// 	],
// 	'728x90': ['']
// }
</script>
	
<script type="text/javascript">
	function loadAdUnit(size, rand) {
		var adWrapper = document.getElementById('adUnit-' + rand);
		var display = window.getComputedStyle(adWrapper).display;
		if (size === 'skin' || display !== "none") {
			unit = adUnits[size].splice(0, 1);
			adWrapper.innerHTML += unit;
		}
	}
</script>
</head>
<body class="tmpl-light side-menu ">
	<div class="adUnit" id="adUnit-1899522219">
<script>loadAdUnit('skin', 1899522219);</script>
</div>
	
<a target="_blank" class="takeover-skin active" href="https://shackpets.shacknews.com/">
	<img alt="Shackpets | Available on iOS and Google Play Store" title="Shackpets | Available on iOS and Google Play Store" src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/ad/shackpets/takeover-skin.webp" width="1920" height="1920" />
</a>


<div id="page" class="page theme2 takeover">
<script>
var theme = localStorage.getItem('theme');
if (theme) {
	document.getElementById('page').classList.remove('theme2');
	document.getElementById('page').classList.add(theme);
}
</script>
	
<div class="modal login">
	<div class="close-modal cover"></div>
	<div class="modal-container-outer">
		<div class="modal-container">
			<iframe data-src="/login/login"></iframe>
			<p>New to Shacknews? <a class="tog-register" href="javascript:;" onclick>Signup for a Free Account</a></p>
		</div>
	</div>
</div>

<div class="modal register">
	<div class="close-modal cover"></div>
	<div class="modal-container-outer">
		<div class="modal-container">
			<iframe data-src="/login/register"></iframe>
			<p>Already have an account? <a class="tog-login" href="javascript:;" onclick>Login Now</a></p>
		</div>
	</div>
</div>

<div class="modal search">
	<div class="close-modal cover"></div>
	<div class="modal-container-outer">
		<div class="modal-container">
			<div class="search-form">
				<form method="get" action="/editorial-search/" class="ignore-form-style">
					<input id="main-search-input" name="q" type="text" placeholder="Search" />
					<span class="tmpl-icon mini"></span>
				</form>
			</div>
		</div>
	</div>
</div>

<header class="primary">
	<div class="header-top">
		<div class="in">
			<div class="grim-fandango"><a href="/article/126678/2022-video-game-release-dates-calendar"><span class="nh2">2022 video game release dates calendar</span></a><a href="/article/101225/destiny-2-complete-strategy-guide"><span class="nh2">Destiny 2 Complete Strategy Guide</span></a><a href="/article/128105/shacknews-hall-of-fame"><span class="nh2">Shacknews Hall of Fame</span></a><a href="/article/129163/vow-of-the-disciple-raid-guide-destiny-2"><span class="nh2">Vow of the Disciple raid guide - Destiny 2</span></a><a href="/article/129551/elden-ring-strategy-guide"><span class="nh2">Elden Ring strategy guide</span></a></div>

			<div class="social">
								<a href="javascript:;" class="toggle-lola"><span>Lola</span><span class="tmpl-icon mini"></span></a>
				
				<ul>
					<li class="facebook"><a href="https://www.facebook.com/shacknews"><span class="tmpl-icon mini"></span><span class="brand-name">Facebook</span></a></li>
					<li class="twitter"><a href="https://twitter.com/shacknews"><span class="tmpl-icon mini"></span><span class="brand-name">Twitter</span></a></li>
					<li class="youtube"><a href="https://www.youtube.com/user/Shacknewsgames"><span class="tmpl-icon mini"></span><span class="brand-name">Youtube</span></a></li>
					<li class="twitch"><a href="https://www.twitch.tv/shacknews"><span class="tmpl-icon mini twitch-icon"></span><span class="brand-name">Twitch</span></a></li>
					<li class="rss"><a href="https://www.shacknews.com/feed/rss"><span class="tmpl-icon mini"></span><span class="brand-name">Subscribe</span></a></li>
				</ul>
			</div>
		</div>
	</div>
	<div class="header-bottom">
		<div class="in">
			<div class="logo"><a href="https://www.shacknews.com/"><img alt="Shacknews Logo" src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/brand/project-logo.webp" width="auto" height="48" /></a></div>
			<div class="logo alt"><a href="https://www.shacknews.com/"><img alt="Shacknews Logo" src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/brand/project-logo-alt.webp" height="48" width="auto" /></a></div>
			<div class="primary-menu-button tmpl-icon mini"></div>
			<div class="mobile-modal header-bottom-right">
				<div class="close-modal cover"></div>
				<div class="modal-container-outer">
					<div class="modal-container">
						<div class="tools">
							<ul>
																<li class="expandable"><a href="javascript:;" onclick class="theme-switcher"><span class="flex-me"><span class="tmpl-icon mini"></span> <span class="mobile-only">Theme</span></span></a></li>
																								<li class="expandable"><a href="/cortex/articles"><span class="flex-me"><span class="tmpl-icon mini"></span> <span class="mobile-only">Cortex</span></span></a></li>
								<li><a href="javascript:;" onclick class="tog-login"><span class="tmpl-icon mini"></span> <span>Log In / Register</span></a></li>
								<li>
																		<a href="/chatty"><span class="tmpl-icon mini"></span> <span>Forum: Posts today 1290</span></a>
																	</li>
																<li class="expandable drop-down-parent">
									<a href="javascript:;" onclick class="drop-down-heading"><span class="flex-me"><span class="tmpl-icon mini"></span> <span class="mobile-only">Topics</span></span></a>
									<ul class="drop-down">
										<li><a href="/topic/review/">Reviews</a></li>
										<li><a href="/topic/news/">News</a></li>
										<li><a href="/topic/video/">Videos</a></li>
										<li><a href="/topic/guide/">Guides</a></li>
										<li><a href="/topic/podcast/">Podcasts</a></li>
										<li><a href="/topic/feature/">Features</a></li>
										<li><a href="/topic/long-read/">Long Reads</a></li>
									</ul>
								</li>
								<li class="expandable"><a href="javascript:;" onclick class="tog-search"><span class="flex-me"><span class="tmpl-icon mini"></span> <span class="mobile-only">Search</span></span></a></li>
							</ul>
						</div>
						<nav class="primary">
							<ul class="tags">
																<li><a href="/topic/destiny-2">Destiny 2</a></li>
																<li><a href="/topic/covid-19">COVID-19</a></li>
																<li><a href="/topic/elden-ring">Elden Ring</a></li>
																<li><a href="/topic/gme">GME</a></li>
																<li><a href="/topic/ps5">PS5</a></li>
																<li><a href="/topic/twtr">TWTR</a></li>
																<li><a href="/topic/black-lives-matter">Black Lives Matter</a></li>
															</ul>
						</nav>
						<div class="grim-fandango"><a href="/article/126678/2022-video-game-release-dates-calendar"><div class="nh2">2022 video game release dates calendar</div></a><a href="/article/101225/destiny-2-complete-strategy-guide"><div class="nh2">Destiny 2 Complete Strategy Guide</div></a><a href="/article/128105/shacknews-hall-of-fame"><div class="nh2">Shacknews Hall of Fame</div></a><a href="/article/129163/vow-of-the-disciple-raid-guide-destiny-2"><div class="nh2">Vow of the Disciple raid guide - Destiny 2</div></a><a href="/article/129551/elden-ring-strategy-guide"><div class="nh2">Elden Ring strategy guide</div></a></div>
					</div>
				</div>
			</div>
		</div>
	</div>
	</header>
	
<article id="detail-view">
	<script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"Article","url":"https:\/\/www.shacknews.com\/article\/131258\/shacknews-pgtc-stranger-things-4-review","mainEntityOfPage":true,"headline":"Shacknews Presents: Pop! Goes the Culture! - Episode 72","datePublished":"2022-07-07T12:30:00-07:00","dateModified":"2022-07-07T12:12:37-07:00","publisher":{"@type":"Organization","name":"Shacknews","logo":{"@type":"ImageObject","url":"https:\/\/d1lss44hh2trtw.cloudfront.net\/deploy\/www-a3b4353\/brand\/project-logo.png"}},"author":{"@type":"Person","name":"Donovan Erskine"},"image":{"@type":"ImageObject","url":"https:\/\/d1lss44hh2trtw.cloudfront.net\/assets\/article\/2022\/07\/07\/pop-goes-the-culture-logo_feature.jpg","width":1920,"height":1080}}</script>
																				<section class="article-content">
		<div class="article-content-wrapper in">
			<main>
															
<div class="article-image banner">
	<div class="overlay cover"></div>
		<picture>
		<source
			media="(min-width:769px)"
			srcset="
				https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=1032&sign=zjnGsUCfbmtXVSPoy4xDtJxoVc11HTAkR1Wyuy6dyVE 1x,
				https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=2064&sign=bZdNc6MFKvOhHGmE5eA56_yM9iRajyRb0Z1W9Z8bco4 2x,
				https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=2064&sign=bZdNc6MFKvOhHGmE5eA56_yM9iRajyRb0Z1W9Z8bco4 3x,"
		>
		<source
			media="(max-width:390px)"
			srcset="
				https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=354&sign=u4QQM7-SUPGGudSnI7bs5sv0X9kf5T3fwNfV6ZUGbBI 1x,
				https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=708&sign=eh4gjfCd6XcsYBCOz7gl5wn9Yr_dhJ4SUbAwhbxwcog 2x,
				https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=708&sign=eh4gjfCd6XcsYBCOz7gl5wn9Yr_dhJ4SUbAwhbxwcog 3x,"
		>
		<source
			media="(max-width:768px)"
			srcset="
				https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=768&sign=w604V-HZLh3Wea7GaZh4aBaZFefZQOsE-ng6khQp1Tk 1x,
				https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=1536&sign=bQKyMrC7qifM5OwAzxFOHl45HYz1Hw4D9-6L-WwYvQY 2x,
				https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=1536&sign=bQKyMrC7qifM5OwAzxFOHl45HYz1Hw4D9-6L-WwYvQY 3x,"
		>
		<img
			src="https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fpop-goes-the-culture-logo_feature.jpg&width=1032&sign=zjnGsUCfbmtXVSPoy4xDtJxoVc11HTAkR1Wyuy6dyVE"
			title="Shacknews Presents: Pop! Goes the Culture! - Episode 72"
			alt="Shacknews Presents: Pop! Goes the Culture! - Episode 72"
			width="1032" height="581"		>
	</picture>
	</div>
<div class="article-lead-content">
	<div class="article-lead-top">
					<ul class="tags">
									<li><a href="https://www.shacknews.com/topic/video/">Video</a></li>
							</ul>
			</div>
	<div class="article-lead-middle">
		<div class="article-lead-bottom-content">
			<h1 class="article-title">Shacknews Presents: Pop! Goes the Culture! - Episode 72</h1>
			<description><p>It's time for some more exciting movie and tv talk. Get in here!</p></description>
		</div>
	</div>
	<div class="article-lead-bottom">
		<div class="meta">
			<div class="attribution">
									<a href="https://www.shacknews.com/author/donovan-erskine" class="author-pic">
						<img src="https://d1lss44hh2trtw.cloudfront.net/resize?height=108&type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Fauthor%2F2018%2F08%2F14%2Fme-e3_512x512.jpg&width=108&sign=ocwXkhMH8tEuqtz_6UyW7epa6cxEnNDLoWwKfSXaJ6E" alt="Donovan Erskine" title="Donovan Erskine"
						width="108" height="108"
						>
				</a>
								<div class="by-line">
					<address class="nh3"><a href="https://www.shacknews.com/author/donovan-erskine">Donovan Erskine</a></address>
				</div>
			</div>
			<div class="time-stamp"><time datetime="2022-07-07T12:30:00-07:00">July 7, 2022 12:30 PM</time></div>
						<div class="tools">
								<a href="#chatty" class="chatty-thread">1</a>
			</div>
		</div>
	</div>
</div>
												<p>Happy Thursday to you! Not only is it almost the end of the week, but it's time for Pop! Goes the Culture! We've got a lot of interesting movie and TV news to discuss this week, so come join hosts Donovan and Greg!</p>
<p>Episode 72 of Pop! Goes the Culture! goes live on the Shacknews <a href="https://www.twitch.tv/shacknews" target="_blank" rel="noopener">Twitch Channel</a> today at <strong>1:00 p.m. PT/ 4:00 p.m. ET</strong>. The stream is available to watch right here using the embed below.</p>
<p><iframe width="620" height="378" scrolling="no" allowfullscreen="allowfullscreen" frameborder="0" src="https://player.twitch.tv/?channel=shacknews&amp;parent=www.shacknews.com"></iframe></p>
<p>Here&rsquo;s a rundown of some of the news topics featured on today&rsquo;s Pop! Goes the Culture!:</p>
<ul>
<li><a href="https://www.youtube.com/watch?v=0_lFOqQDRx0" target="_blank" rel="noopener">First trailer for Clerks 3</a></li>
<li><a href="https://bloody-disgusting.com/movie/3722068/duffer-brothers-launching-upside-down-pictures-with-stranger-things-spinoff-and-stephen-kings-talisman-series/" target="_blank" rel="noopener">Duffer Bros. create Upside Down Pictures, reveal new projects</a></li>
<li><a href="https://www.youtube.com/watch?v=3RDaPV_rJ1Y" target="_blank" rel="noopener">First trailer for The Woman King</a></li>
<li><a href="https://variety.com/2022/digital/news/playstation-store-pulling-access-to-purchased-studiocanal-movies-next-month-1235310863/" target="_blank" rel="noopener">PlayStation Store will revoke access to purchased StudioCanal movies in some countries</a></li>
</ul>
<hr />
<p>There are plenty of things to discuss on this week's PGTC. The Clerks series is back with the first trailer for Clerks 3, as well as a new trailer for The Woman King. Also, Stranger Things creators the Duffer Brothers have created their own studio, and have multiple projects in the works.</p>
<p>We appreciate you stopping by to check out our show! If you&rsquo;re looking for a way to show even more support for our livestreaming efforts at Shacknews, you can use your free monthly Prime Gaming subscription via <a href="https://www.shacknews.com/article/104272/how-to-get-twitch-prime-by-linking-an-amazon-prime-account" target="_blank" rel="noopener">Amazon Prime</a>.</p>
<p>Find your seats and silence your phones, It&rsquo;s time for episode 72 of Pop! Goes the Culture!</p>
<div class="author-short-bio">
	<div class="short-bio-heading">
				<div class="author-pic">
			<a href="https://www.shacknews.com/author/donovan-erskine">
				<img src="https://d1lss44hh2trtw.cloudfront.net/resize?height=108&type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Fauthor%2F2018%2F08%2F14%2Fme-e3_512x512.jpg&width=108&sign=ocwXkhMH8tEuqtz_6UyW7epa6cxEnNDLoWwKfSXaJ6E" alt="News Editor" title="News Editor"
				width="108" height="108"
				/>
			</a>
		</div>
				<div>
			<address itemprop="author" class="nh3"><a href="https://www.shacknews.com/author/donovan-erskine">Donovan Erskine</a></address>
			<div class="nh5">News Editor</div>
		</div>
	</div>
	<div class="author-about">
		<p>Donovan is a young journalist from Maryland, who likes to game. His oldest gaming memory is playing Pajama Sam on his mom's desktop during weekends. Pok&eacute;mon Emerald, Halo 2, and the original Star Wars Battlefront 2 were some of the most influential titles in awakening his love for video games. After interning for Shacknews throughout college, Donovan graduated from Bowie State University in 2020 with a major in broadcast journalism and joined the team full-time. He is a huge Star Wars nerd and film fanatic that will talk with you about movies and games all day. You can follow him on twitter <a href="https://twitter.com/Donimals_" target="_blank" rel="noopener">@Donimals_</a></p>	</div>
</div>

				<div class="tags-block">
	<div class="nh3">Filed Under</div>
	<ul class="tags article-footer clear-fix">
		<li><a href="https://www.shacknews.com/topic/television/">television</a></li>
		<li><a href="https://www.shacknews.com/topic/livestream/">Livestream</a></li>
		<li><a href="https://www.shacknews.com/topic/video/">Video</a></li>
		<li><a href="https://www.shacknews.com/topic/movies/">movies</a></li>
		<li><a href="https://www.shacknews.com/topic/shackstream/">ShackStream</a></li>
		<li><a href="https://www.shacknews.com/topic/pop-goes-the-culture/">Pop! Goes the Culture!</a></li>
		</ul>
</div>
			</main>
						<div id="side-rail">
				<div class="side-rail-container">
					<div class="ad internal vert">
							<div class="adUnit" id="adUnit-59110522">
<script>loadAdUnit('300', 59110522);</script>
</div>					</div>
					    <section id="related">
        <div class="in">
            <div class="module article-list">
                <header>
                    <div class="nh3">Related Stories</div>
                </header>
                <div class="content">
                                            <article class="list-item">
                            <a class="article-image" href="https://www.shacknews.com/article/131244/shackstream-big-team-building-ep-23">
                                <picture>
                                    <source
                                        media="(min-width:1px)"
                                        srcset="
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fshackstream-big-team-building-rocket-league-episode-23_688x387.jpg&width=64&sign=RmNFF36WqzxiAUs0FbYmISE8ELH_m0KSgZ8uVhDWJzU 1x,
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fshackstream-big-team-building-rocket-league-episode-23_688x387.jpg&width=128&sign=C60XEAtBhMmL30UA2DIHl-A39E2CndkqD2Lp_s6l24E 2x,
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F07%2Fshackstream-big-team-building-rocket-league-episode-23_688x387.jpg&width=256&sign=9kNHqM0CEAJZNsv6rmDQ5jS7LPQRvK4-b22MPCjRrzg 3x,"
                                    >
                                    <img src="https://d1lss44hh2trtw.cloudfront.net/assets/article/2022/07/07/shackstream-big-team-building-rocket-league-episode-23_688x387.jpg" alt="ShackStream: Big Team Building in Rocket League - Episode 23" title="ShackStream: Big Team Building in Rocket League - Episode 23"
                                    width="688" height="387"
                                    />
                                </picture>
                            </a>
                            <a class="article-content" href="https://www.shacknews.com/article/131244/shackstream-big-team-building-ep-23"><div class="nh3">ShackStream: Big Team Building in Rocket League - Episode 23</div></a>
                        </article>
                                            <article class="list-item">
                            <a class="article-image" href="https://www.shacknews.com/article/131234/skull-and-bones-gameplay-reveal">
                                <picture>
                                    <source
                                        media="(min-width:1px)"
                                        srcset="
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F06%2Fskull-and-bones_688x387.jpg&width=64&sign=agObKvG4S7f7FYTwvs76de6UMpRNkHSkxAOYzRpH9T0 1x,
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F06%2Fskull-and-bones_688x387.jpg&width=128&sign=Ws0r2vznZYCbylg7IDxMGkmqPxyHdASoJ8ym7gqIxZc 2x,
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F06%2Fskull-and-bones_688x387.jpg&width=256&sign=XgLW-ytk3j0t-AzvDza7KytnmaudZwkHZSxwJmuJmYk 3x,"
                                    >
                                    <img src="https://d1lss44hh2trtw.cloudfront.net/assets/article/2022/07/06/skull-and-bones_688x387.jpg" alt="Watch the Skull and Bones worldwide gameplay reveal here" title="Watch the Skull and Bones worldwide gameplay reveal here"
                                    width="688" height="387"
                                    />
                                </picture>
                            </a>
                            <a class="article-content" href="https://www.shacknews.com/article/131234/skull-and-bones-gameplay-reveal"><div class="nh3">Watch the Skull and Bones worldwide gameplay reveal here</div></a>
                        </article>
                                            <article class="list-item">
                            <a class="article-image" href="https://www.shacknews.com/article/131240/shackstream-the-stevetendo-show-episode-211">
                                <picture>
                                    <source
                                        media="(min-width:1px)"
                                        srcset="
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F06%2Fmarioluigsss_688x387.jpg&width=64&sign=Eoje8ZqNQ6pNljvx_dosvVB4wxLVYhWeQSJopT0d0tk 1x,
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F06%2Fmarioluigsss_688x387.jpg&width=128&sign=KhE-i7QVXAWGpzc-EJMAsOMpX50M-fmg3hLvPWW7BRs 2x,
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F06%2Fmarioluigsss_688x387.jpg&width=256&sign=rP57By4hwtD-qrriQtUIUCu8n4Eni42YPezGNi_T_cU 3x,"
                                    >
                                    <img src="https://d1lss44hh2trtw.cloudfront.net/assets/article/2022/07/06/marioluigsss_688x387.jpg" alt="ShackStream: The Stevetendo show! Episode 211" title="ShackStream: The Stevetendo show! Episode 211"
                                    width="688" height="387"
                                    />
                                </picture>
                            </a>
                            <a class="article-content" href="https://www.shacknews.com/article/131240/shackstream-the-stevetendo-show-episode-211"><div class="nh3">ShackStream: The Stevetendo show! Episode 211</div></a>
                        </article>
                                            <article class="list-item">
                            <a class="article-image" href="https://www.shacknews.com/article/131242/why-weapons-arent-part-of-hearthstone-murder-at-castle-nathria">
                                <picture>
                                    <source
                                        media="(min-width:1px)"
                                        srcset="
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F06%2Fearhsotme_688x387.jpg&width=64&sign=p5dFYciefC_q-qYQKi4GNKaAIpwtY2DoioUEKg3hPfE 1x,
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F06%2Fearhsotme_688x387.jpg&width=128&sign=dBWNQn5I5pQKvSocXb5ecB74ZhYxhyH_Ogy4k6RDlc0 2x,
                                            https://d1lss44hh2trtw.cloudfront.net/resize?type=webp&url=https%3A%2F%2Fshacknews-www.s3.amazonaws.com%2Fassets%2Farticle%2F2022%2F07%2F06%2Fearhsotme_688x387.jpg&width=256&sign=u_LqiGKKZoyxJ0v0DjrOtQA41gUjjVbYrqSIu_AwDC0 3x,"
                                    >
                                    <img src="https://d1lss44hh2trtw.cloudfront.net/assets/article/2022/07/06/earhsotme_688x387.jpg" alt="Why class weapons aren't part of Hearthstone: Murder at Castle Nathria" title="Why class weapons aren't part of Hearthstone: Murder at Castle Nathria"
                                    width="688" height="387"
                                    />
                                </picture>
                            </a>
                            <a class="article-content" href="https://www.shacknews.com/article/131242/why-weapons-arent-part-of-hearthstone-murder-at-castle-nathria"><div class="nh3">Why class weapons aren't part of Hearthstone: Murder at Castle Nathria</div></a>
                        </article>
                                    </div>
            </div>
        </div>
    </section>
									</div>
			</div>
					</div>

		
		
	<script src="https://www.shacknews.com//js/js-app-bundle/site_frontend_page.js"></script>
    <script>
        window.CHATTY_BASE_URL = "https:\/\/www.shacknews.com\/";
    </script>
	<div class="article-chatty" id="chatty">
		<div class="in">
			<header>
				<div class="nh3">From The Chatty</div>
				<div class="tools">
					<a href="javascript:;" onclick class="refresh-thread">Refresh</a>
					<a href="/chatty?id=41382468" class="chatty-link">Go To Thread</a>
				</div>
			</header>
						<ul>
					<li class="comment" id="item_41382468">
		<div class="bubble">
			<div class="existing-content">
				<div class="comment-info">
					<a class="avatar"></a>
					<div class="comment-meta">
						<div class="top-line">
							<a class="author" href="/user/Shacknews/posts">Shacknews</a>
														<img class="chatty-icons" alt="legacy 10 years" src="https://www.shacknews.com/images/icons/legacy-10-years.png" title="legacy 10 years" src="https://www.shacknews.com/images/icons/legacy-10-years.png" />
														<img class="chatty-icons" alt="legacy 20 years" src="https://www.shacknews.com/images/icons/legacy-20-years.png" title="legacy 20 years" src="https://www.shacknews.com/images/icons/legacy-20-years.png" />
													</div>
						<div class="bottom-line">
							<a class="close-thread tmpl-icon mini" href="javascript:;"></a>
							<a class="reply" href="#" data-parent-id="41382468">reply</a>
							<div class="timestamp">July 7, 2022 12:30 PM</div>
						</div>
					</div>
				</div>
				<p class="quote">
					Donovan Erskine posted a new article, <a target="_blank" href="/article/131258/shacknews-pgtc-stranger-things-4-review">Shacknews Presents: Pop! Goes the Culture! - Episode 72</a>				</p>
			</div>
		</div>

			</li>
			</ul>
					</div>
	</div>
	<div id="chatty-reply-template" style="display: none">
					<a href="#" class="tog-login">Login / Register</a>
			</div>
	</section>
</article>
<script>
articleId = "131258";
articleIdType = 'editorial';
</script>
	

<div class="lola-affirmation">
	<img alt="Hello, Meet Lola" src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/images/mercury/lola-affirmation.webp" width="500" height="391" />
</div>

<footer class="primary">
	<div class="in">
		<div class="footer-left">
			<div class="logo"><a href="https://www.shacknews.com/"><img alt="Shacknews Logo" src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/brand/project-logo.png" /></a></div>
			<div class="logo alt"><a href="https://www.shacknews.com/"><img alt="Shacknews Logo" src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/brand/project-logo-alt.png" height="32" width="173" /></a></div>
			<div>&copy; 1996 - 2022 Shacknews LTD.</div>
		</div>
		<div class="footer-right">
			<ul>
				<li class="heading">Company</li>
				<li><a href="/pages/about/">About Shacknews</a></li>
				<li><a href="https://shackpets.shacknews.com/welcome/">Shackpets</a></li>
				<li><a href="/pages/contact-us/">Contact Us</a></li>
				<li><a href="/pages/privacy-policy/">Privacy Policy</a></li>
				<li><a href="/pages/tos">Terms of Service</a></li>
			</ul>
			<ul>
				<li class="heading">Do It For Shacknews</li>
				<li><a href="https://www.facebook.com/shacknews">Facebook</a></li>
				<li><a href="https://twitter.com/shacknews">Twitter</a></li>
				<li><a href="http://www.twitch.tv/shacknews">Twitch</a></li>
				<li><a href="https://www.youtube.com/user/Shacknewsgames">Youtube</a></li>
				<li><a href="/feed/rss">Subscribe</a></li>
			</ul>
		</div>
	</div>
	<div style="display: none !important"><img alt="Shacknews Logo" src="https://d1lss44hh2trtw.cloudfront.net/deploy/www-a3b4353/signature/personal-twitter.png" /></div>
</footer>

	</div>
	</body>
</html>
